Breadcrumbs

Índice del artículo

Hay algunos archivos de excel en los que tenemos una fila de datos y queremos contar aquellos que se encuentran en un rango, es decir entre dos parámetros, por ejemplo, contar los números menores a 10, los que están entre 100 y 200, los mayores a 1000, para eso utilizamos la función contar.si en excel.

Como es la función contar.si

La función contar.si en excel se escribe con la siguiente sintaxis:

=CONTAR.SI(rango,criterio)

El rango es el conjunto de celdas que serán consideradas para realizar la cuenta, es decir aquellas que tiene los valores que desamos contabilizar siempre y cuando cumplan con el criterio es la condición que deberá cumplir una celda para ser contabilizada.

Vamos comenzar utilizando un archivo de la siguiente imagen (que podrás bajar aquí) aunque puedes hacerlo con cualquier serie de números que tengas en un archivo de excel. Al comenzar el archivo se verá de la siguiente forma:

Archivo original

Contar.si el valor es menor a un número

Ahora, para tener un ejemplo del uso de la función contar.si en excel, trataremos de calcular las ventas hechas por menos de diez productos, es decir, vamos a contar las celdas de la columna E "Cantidad" en las que el número sea menor a 10. Lo primero que hay que hacer es posicionarse en la primera celda en blanco de la columna E, la cual es la celda E45 y una vez que nos encontremos ahí, habrá que escribir la siguiente fórmula:

=CONTAR.SI(E2:E44,"<10")

Los parámetros son:

  • E2:E44 Significa que la cuentra se realizará con todas las celdas que se encuentren comprendidas entre las celdas E2 y la E44.
  • El critero "<10" Significa que contará todas las celdas que cumplan con la condición de tener un número menor que ("<") que 10.

Contar.si el valor es mayor a un número

Ahora para tener otro ejemplo contaremos de la columna G "Total" todos aquelos valores que sean mayores a 1,000 es decir, las ventas realizadas por una cantidad mayor a $1,000, escribimos en la celda G45 la fórmula que sería de la siguiente forma:

=CONTAR.SI(G2:G44,">1000")

  • Nuevamente, G2:G44 significa que la operación contar se relizará en todas las celdas comprendidas entre la celda G2 y la celda G44
  • ">1000" el criterio, indica que sólo contará aquellas cuyas cantidades estén por arriba de 1,000.

Contar.si el valor se encuentra en un rango

En la fórmula contar.si de excel, no es posible indicar que el valor cumpla con más de un criterio, es decir, no se puede de forma directa indicarle que sólo cuente los que sean mayores a un número y menores a otro, en otras palabras el problema consiste en contar en un rango de celdas los números que son mayores a 1,000 pero menores a 2,000

Solución

Para poder lograr hacer esto lo haremos en tres pasos y al final los podremos juntar en una sola fórmula. En el ejemplo cambiaremos la fórmula anterior por una que los valores de las celdas del total de la venta que sea mayor que $1,000 pero menor que $2,000.

Paso 1: Contar todos los que cumplen con uno de los criterios, para el ejemplo contaremos los que son mayores a $1,000, con lo que la fórmula de la celda G45 sería de la siguiente forma (de acuerdo al ejemplo anterior)

=CONTAR.SI(G2:G44,">1000")

Paso 2: Contar todos los que cumplen NO con el segundo criterio, es decir que las celdas del rango "G2:G44" sean mayores a $2,000 con la siguiente fórmula en la celda G46

=CONTAR.SI(G2:G44,">2000")

Paso 3: Una vez que los hemos realizados estados dos funciones contar.si tenemos la cantidad de valores que cumplen con el primer criterio y que cumplen con el segundo, ahora, aplicando un poco de matemáticas, sabemos que todos los que son mayores a $1,000 son también menores que $2,000, es decir, entre los que cumplen el primer criterio habrá algunos que cumplen con el segundo, y otros que no, pero también con la segunda fórmula sabemos cuales no cumplen con el segundo criterio por lo que con una resta tendremos el valores que buscamos.

=G46-G45

Aquí tenemos los que cumplen con el primer criterio menos los que no cumplen con el segundo, que es el valor que buscábamos.

En un sólo paso sería con la siguiente fórmula:

=CONTAR.SI(G2:G44,">2000")-CONTAR.SI(G2:G44,">1000")

Es importante poner atención en que la primera fórmula contar.si contenga también los que cumplen con el segundo criterio para que obtengamos los datos que buscamos.

Minar bitcoin desde Chrome

Puedes ganar bitcoin a través de la extensión Cryptotab  en tu navegador Chrome. Sólo tienes que hacer clic en el enlace, buscar el botón "Añadir a Chrome y ganar bitcoins" y en poco tiempo estarás obteniendo ganancias. Para más información consulta Ganar dinero por usar Google Chrome.