Breadcrumbs

Índice del artículo

Contar.si el valor se encuentra en un rango

En la fórmula contar.si de excel, no es posible indicar que el valor cumpla con más de un criterio, es decir, no se puede de forma directa indicarle que sólo cuente los que sean mayores a un número y menores a otro, en otras palabras el problema consiste en contar en un rango de celdas los números que son mayores a 1,000 pero menores a 2,000

 

Solución

Para poder lograr hacer esto lo haremos en tres pasos y al final los podremos juntar en una sola fórmula. En el ejemplo cambiaremos la fórmula anterior por una que los valores de las celdas del total de la venta que sea mayor que $1,000 pero menor que $2,000.

Paso 1: Contar todos los que cumplen con uno de los criterios, para el ejemplo contaremos los que son mayores a $1,000, con lo que la fórmula de la celda G45 sería de la siguiente forma (de acuerdo al ejemplo anterior)

=CONTAR.SI(G2:G44,">1000")

Paso 2: Contar todos los que cumplen NO con el segundo criterio, es decir que las celdas del rango "G2:G44" sean mayores a $2,000 con la siguiente fórmula en la celda G46

=CONTAR.SI(G2:G44,">2000")

Paso 3: Una vez que los hemos realizados estados dos funciones contar.si tenemos la cantidad de valores que cumplen con el primer criterio y que cumplen con el segundo, ahora, aplicando un poco de matemáticas, sabemos que todos los que son mayores a $1,000 son también menores que $2,000, es decir, entre los que cumplen el primer criterio habrá algunos que cumplen con el segundo, y otros que no, pero también con la segunda fórmula sabemos cuales no cumplen con el segundo criterio por lo que con una resta tendremos el valores que buscamos.

=G46-G45

Aquí tenemos los que cumplen con el primer criterio menos los que no cumplen con el segundo, que es el valor que buscábamos.

En un sólo paso sería con la siguiente fórmula:

=CONTAR.SI(G2:G44,">2000")-CONTAR.SI(G2:G44,">1000")

Es importante poner atención en que la primera fórmula contar.si contenga también los que cumplen con el segundo criterio para que obtengamos los datos que buscamos.

Como ganar dinero vendiendo tus fotos

Hay una gran diversidad de sitios web en donde puedes vender tus fotos, cada uno tiene sus políticas, condiciones, registro etc. Si tu quieres comenzar a tener un ingreso extra vendiendo tus fotografías en línea a través te estos sitios, te recomendamos suscribirte a Photography Jobs Online donde tendrás las herramientas y consejos necesarios para  tener un dinero adicional e incluso, si es de tu interés, emprender tu negocio como fotógrafo profesional.